Moka5
Moka5


Improve Performance of a LivePC   « Go Back
Table of Contents
- Summary
- Pre-Requisites
- Steps



Summary


This article describes steps that you can take if you experience poor performance in a LivePC.



Pre-Requisites



Steps


Anti-Virus (AV) running in the LivePC

Causes:

  • Excessive scanning can be triggered due to the nature of layering. In these cases, when a LivePC is started, the AV application believes that EACH start is the first time run for the AV application. Most AV applications are configured to scan the entire drive resulting in slow performance for the LivePC.
  • MokaFive layering uses a low level kernel driver for Windows LivePCs. AV software sometimes believes that MokaFive is a virus.

Symptoms:

  • Very slow performance in the LivePC on startup
  • Alerts from the AV software about infections

Solutions:

  1. Disable the AV in the guest to determine if this is the cause of the problem.
  2. As a next step, re-enable the agent in the guest but reduce the security level settings and test LivePC performance.
  3. Further tuning can include changing the targeted AV scan on a layered LPC to scan N:\ and M:\ only. These drives contain the read-write files that could be infected. This should shorten the scan time considerably.
  4. One last step to consider is changing the scheduled frequency of ‘full scans’ to avoid impacts on performance in the guest occurring too often.

Data Loss Prevention (DLP) in the LivePC

Causes:

  • MokaFive layering uses a low level kernel driver for Windows LivePCs.
  • DLP software sometimes believes that MokaFive may be a possible unauthorized exit point.

Solutions:

  1. Disable the DLP to determine if this is the cause of the problem.
  2. As a next step, re-enable the agent in the guest but reduce the security level settings and test LivePC performance.
  3. If lowering the general security level does not resolve the issue, add all MokaFive guest services to the DLP exception list.
  • To get the list of all MokaFive guest services, in Windows 7, go to the Start Menu -> Search box -> type in "services" -> open the Services manager. Sort the services by name and get all the MokaFive services.

First Time Domain Join or General Long Boot Times

Causes:

  • The first time a user boots their LivePC after subscribing, the boot time will be slow as user profiles, etc are getting setup.
  • GPOs or other application management tools will kick in when booting the LivePC for the first time when joined to the domain and logging in as a domain user. The delay experienced here will be dependent upon the number of GPOs and the configuration actions on the LivePC.
  • GPOs or application distribution tools in the guest may be installing applications at first boot resulting in a long boot time.

Solutions:

  1. Try a boot of the LivePC without domain join packets to get a baseline on the performance without the GPOs being applied. For this reason, we always recommend publishing a version of the LivePC before joining it to the domain first.
  2. In Active Directory, move to the LivePC to another OU or security group where there are no GPOs being applied to the LivePC.
  • After the LivePC is moved, go to Start -> Search box -> type in "gpupdate /force" and hit ENTER. This will force the GPOs to be updated on the LivePC.
  • Reboot the LivePC and verify if there are any performance changes without all the GPOs applied.
  • Review all your GPO settings and re-apply them to the LivePC until you can determine the settings that may be affecting performance.